I've been trying to build res-rsa-2.9.2 with gmp-3.0.1, but due to a few
issues, it hasn't worked.

Setup: I'm compiling on Solaris 7/Sparc, with gcc and gnu make.

The instructions we have say to use "--with-gmp=../gmp-X.Y.Z" when compiling
res-rsa, but this doesn't work anymore, since the gmp folks have apparently
switched to dumping the libs in gmp-X.Y.Z/.lib when you build gmp.  Thus,
res-rsa doesn't find 'em, when including/linking from gmp's src dir.

Second, something else in the library changed, I believe, because I tried
installing libgmp.so.3.0.1 and linking from there ala': --with-gmp=$HOME
(I prefer to install oddball stuff in my homedir first) 
During the linking, the library (libgmp.so) is found, opened and read, but
apparently rejected, since it moves on to other possible locations for the
library.  The output of 'truss -f make mkkey' shows:
[...other lib paths...]
13:     open("/fs/local/lib/libgmp.so", O_RDONLY)       Err#2 ENOENT
13:     open("/fs/local/lib/libgmp.a", O_RDONLY)        Err#2 ENOENT
13:     open("/fs/scd/home0/rsc/lib/libgmp.so", O_RDONLY) = 7
13:     lseek(7, 0, SEEK_END)                           = 422256
13:     mmap(0x00000000, 422256, PROT_READ, MAP_PRIVATE, 7, 0) = 0xFF070000
13:     fstat(7, 0xFFBEDB28)                            = 0
13:     close(7)                                        = 0
13:     open("/usr/ccs/lib/libgmp.so", O_RDONLY)        Err#2 ENOENT
13:     open("/usr/ccs/lib/libgmp.a", O_RDONLY)         Err#2 ENOENT
13:     open("/usr/lib/libgmp.so", O_RDONLY)            Err#2 ENOENT
13:     open("/usr/lib/libgmp.a", O_RDONLY)             Err#2 ENOENT

So it barfs the library out like Dagoba Swamp Thing upchucking R2D2?
The permissions on the lib were 755, owned by me.

gmp-2.0.2 works fine (of course) but I thought I'd poass this along...

Bob Campbell                    Unix System Administrator
Scientific Computing Division   National Center for Atmospheric Research
rsc at ucar.edu                    (303) 497-1815