Hi I'm trying to compile the latest Vanilla.

First problem I ran into was that gcc didn't like the use
of <varargs.h> so i had to change that to <stdarg.h> in
robotd/util.c, robots/inlcomm.c, robotd/util.c,
sequencer/roboshar.c, tools/html.c, & tools/text.c

After making that hack I was able to get the compile to
proceed but then I ran into another fatal make error:

make[2]: Leaving directory
cd sequencer; make depend
make[2]: Entering directory
gcc -M  -g -O2   -I. -I. -I../include -I./../include
./roboshar.c ./sequencer.c ./../ntserv/commands.c
./../ntserv/data.c ./../ntserv/openmem.c
./../ntserv/smessage.c ./../ntserv/slotmaint.c > .depend
roboshar.c:114:18: macro "va_start" requires 2 arguments,
but only 1 given
roboshar.c:149:18: macro "va_start" requires 2 arguments,
but only 1 given
make[2]: *** [depend] Error 1
make[2]: Leaving directory
make[1]: *** [depend] Error 2
make[1]: Leaving directory `/home/yoda/netrek/Vanilla'
make: *** [null] Error 2

I see this has been a problem in the past. From the
Mon Aug 16 14:15:44 1999	Dave Ahn <ahn at vec.wfubmc.edu>
* BUGFIX pledit/main.c: Pledit was still using varargs
instead of
stdargs, causing problems at compile or run time depending

Any ideas how to resolve this? I have attached my
I also had to hack system.mk to use:  LIBCURSES = -lcurses
For some reason configure.in was not passing this. I was a
bit puzzled also why ./configure complained:

checking for newwin in -lncurses... (cached) no
checking for newwin in -lcurses... (cached) no

yet I have curses.h and ncurses.h installed in my system.

I'm running Linux kernel 2.2.18pre21 with the Debian
GNU/Linux 3.0 distribution.


Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 3550 bytes
Desc: config.log
Url : http://shadowknight.real-time.com/pipermail/netrek-dev/attachments/20030923/4ced99ba/config.obj