Heya, I'm moving the discussion from netrek-forever to the dev mailinglist
since it's definitely more fitting here.

---------- Forwarded message ----------
From: Toumal <toumaltheorca at gmail.com>
Date: Tue, Aug 24, 2010 at 5:14 PM
Subject: [netrek-forever] Can't get pre-t robots working on my server
To: netrek-forever <netrek-forever at googlegroups.com>


I'm sorry if the answer to my question is obvious, but I've read all
the docs and tried for hours and I'm officially out of ideas here.

I'm trying to get either pre-t robots, or newbie mode running on my

I use the default config file with pre-t entertainment mode enabled,
and I can see netrek-daemon spawning the pret process, as well as
several pretbot processes. All these processes name the bot "Banisher"
or something to that effect. The verbose logmode reveals that this
player name does not exist - creating it with an empty password gets
rid of the error but doesn't make things work

The result is that when I connect to my server, I see bots 1 through 7
in grey color in the lest, with no name, no ship type, no kills, no
login and no host machine.
The only other entry I see is no. "v", name "Kathy" and that one shows
"Robot" as login. However, it is also in grey and not playing on the

Now I thought ok, I'll just enable newbie mode. So I set NEWBIE=1 in
the sysdef, and commented out the main player port in etc/ports as
well as uncommenting the three lines for newbie mode. The result is
that I cannot connect to my own server because there are "not enough
player slots in the queue" or something.

I'm really in need of help here. Obviously the robots get started up
but don't work properly, and I have no clue why x.x

On Wed, Aug 25, 2010 at 01:28:32PM +0200, Toumal Rakesh wrote:
> There were a couple problems, I had to change a makefile to have ranlib
> point to "ranlib" instead of "@RANLIB@", and I had to do  chmod +x
> in /tools

        What OS platform and release was this on?  autotools should properly
       handle ranlib detection on everything under the sun these days, and
       configure should properly set the Makefiles.  Did you run
       sh ./autogen.sh before configure?  What version of autoconf and
       automake were you running?

       According to change history, Jerub added the @RANLIB@ checks
       back in May '06; and I've not personally seen 'em fail since.

       James - didn't mktrekon get deprecated?

       On a CentOS box I just pulled a new darcs tree, ran autogen.sh,
       ./configure'd, make -j5  && make install and had no problems
       with the build.

> It compiled okay, but... still the same problem(s): Bots don't join teams
> and newbie mode gives a queue full error x.x

        I can confirm that there does appear to be a problem with newbie
       in that I can't get a normal player slot in, either.  var/log
       doesn't show anything useful even with ERROR_LEVEL=9.  Pulled
       an updated tree from James' development repo and nada, still

       I didn't do anything other than barebones configuration to
       sysdef and ports to enable newbie mode; it is possible I
       overlooked a config step.  ports/sysdef available for review
       at http://stuff.gerdesas.com/ports and

       If I find myself with spare time and an inclination to look
       at the code I will do so later today.

This is all happening because my father didn't buy me a train set as a kid.

-- Warren Buffett, joking about his decision to buy a railroad, the
Northern Santa Fe Corporation, New York Times, 4 November 2009
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.us.netrek.org/pipermail/netrek-dev/attachments/20100825/7e68b36e/attachment.htm