Update: I solved the network performance problem.  I’m currently running ~43 packets per second between my Swift client and the Swift server.

News: I’m pleased to announce a new Netrek game mode: Empire!

Uses standard Bronco clients
All 4 teams active.
Sufficient robots for minimum of 28 players (robots logoff as humans join).
When you join, you are randomly assigned a “home planet”.
You spawn on whatever team controls the planet (if the planet is Indi, then you spawn on the original owner’s team).
When one empire controls 75% of the planets, they win.
If you want to refit ships, you need to do it at your assigned home planet.

As an empire gains planets, it gets more ships/players.  But it might be possible for the 3 other empires to stop a large team from becoming dominant.
Due to the random assignment of players to planets, there in no guarantee that teams will start out even.

I’ve tested that the following clients handle 28 players successfully:

Linux-COW (although the full player list may not be visible)

Server is netrek.networkmom.net <http://netrek.networkmom.net/>

Feel free to login and try it out anytime (warning: I’m restarting the server periodically as I push new features/bugfixes).  I continue to appreciate feedback on the server.

We will have an early adopter test game Tuesday 7/21 6PM Pacific.

Thursday 7/23 is hockey.  We will have a full game Tuesday 7/30 6PM Pacific.

My Swift server is open source at https://github.com/darrellroot/netrek-server-swift <https://github.com/darrellroot/netrek-server-swift>
The server also supports bronco mode with a command-line argument (not yet feature complete)

Major known server issues:

Still no user database / ranks.
Server does not yet implement proper “visibility” rules for distant or cloaked ships.
Missing some starbase features/restrictions
Bronco mode does not have game timers.
Robots are ok dogfighters, but do not currently bomb or capture planets.

Metaserver: For now my server is still reporting server type “B” for bronco.  I will change it to “E” at some point, but I need to push a new MacOS client before I do so.  I might look at COW source and see if I can generate a pull request to handle the E in the metaserver report.  Right now other clients report the server type as “unknown” if it sees an E in the metaserver report.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.us.netrek.org/pipermail/netrek-dev/attachments/20200718/65faebb4/attachment.htm>